Übersetzungen dieser Seite:

Erste Schritte im Umgang mit der Arduino-IDE

HINWEIS: Der USB-Programmer muß am Computer angeschlossen werden, bevor die Arduino IDE gestartet wird.

1. Das Merkur-Board an den Programmer anschließen

Schliesse das Merkur-Board an Deinen Programmer an.

Anschluss des Prolific-USB-TTL-Wandlers als Programmer

Anschluss des FTDI-Basic-USB-TTL-Wandlers als Programmer

2. Programmer an den Computer anschliessen

Stecke den Programmer an den USB-Port Deines Computers.

3. Starte die Arduino IDE

Starte unter Programme Deine Arduino IDE.

4. Das Merkur-Board in der IDE auswählen.

Wähle unter dem Menü Tools→Board den Eintrag Merkur Dev Board aus:

5. Öffne ein neues Programmierfenster

Öffne unter dem Menü Datei→Neu ein neues Programmierfenster aus:

6. Programm eingeben

Gebe in dem Programmierfenster Deinen Quellcode ein:

7. Speichere das Programm ab

Speichere unter dem Menü Datei→Speichern Dein Programm ab.

8. Programmer auswählen

Wähle unter dem Menü Tools→Programmer den Eintrag AVRISP mkll für den angeschlossenen Programmer aus:

9. Schnittstelle auswählen

Wähle unter dem Menü Tools→Serieller Port den Eintrag /dev/tty.usbserial für die USB-Schnittstelle aus, an welcher der Programmer angeschlossen ist.

10. Programm übertragen

HINWEIS: Bei älteren Merkur-Boards (ohne Kondensator an Pin3), muß der Pin 3 (RESET) am Merkur-Board gegen GND gelegt werden, um das Merkur-Boards zu reseten und in den Upload-Modus zu schalten.

Wähle unter dem Menü Datei→Upload, um die Übertragung Deines Programmes in das Merkur-Board zu starten.

Zurück zur Tutorial-Übersicht


de/tutorials/first_steps_arduino_ide.txt · Zuletzt geändert: 2014/06/23 16:54 von stefan